Is aws/aws-sdk-php 2.0 vulnerable?
Composer · 4 releases from 2.0.0 to 2.0.3 · latest aws/aws-sdk-php is 3.402.5 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. aws/aws-sdk-php 2.0.3, the last 2.0 release, is affected by 2 known security advisories (2 medium), including CVE-2025-14761, CVE-2023-51651. Upgrade to 3.368.0 or later to fix all of them.
composer require aws/aws-sdk-php:^3.368.0Advisories affecting aws/aws-sdk-php 2.0.3
AWS SDK for PHP's S3 Encryption Client has a Key Commitment Issue
- Affected
- <3.368.0
- Fixed in
- 3.368.0
Potential URI resolution path traversal in the AWS SDK for PHP
- Affected
- <3.288.1
- Fixed in
- 3.288.1
Which of your client projects are still on aws/aws-sdk-php 2.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact aws/aws-sdk-php version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other aws/aws-sdk-php versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.