Is aws/aws-sdk-php 3.16 vulnerable?

Composer · 1 release from 3.16.0 to 3.16.0 · latest aws/aws-sdk-php is 3.402.5 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. aws/aws-sdk-php 3.16.0, the last 3.16 release, is affected by 3 known security advisories (1 high, 2 medium), including CVE-2025-14761, CVE-2023-51651. Upgrade to 3.371.4 or later to fix all of them.

Upgrade with:composer require aws/aws-sdk-php:^3.371.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting aws/aws-sdk-php 3.16.0

  • HighGHSA-27qh-8cxx-2cr527 Mar 2026

    AWS SDK for PHP has CloudFront Policy Document Injection via Special Characters

    Affected
    >=3.11.7 <3.371.4
    Fixed in
    3.371.4
  • MediumCVE-2025-14761GHSA-x8cp-jf6f-r4xh18 Dec 2025

    AWS SDK for PHP's S3 Encryption Client has a Key Commitment Issue

    Affected
    <3.368.0
    Fixed in
    3.368.0
  • MediumCVE-2023-51651GHSA-557v-xcg6-rm5m21 Dec 2023

    Potential URI resolution path traversal in the AWS SDK for PHP

    Affected
    <3.288.1
    Fixed in
    3.288.1

Which of your client projects are still on aws/aws-sdk-php 3.16?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact aws/aws-sdk-php version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other aws/aws-sdk-php versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.