Is aws/aws-sdk-php 3.342 vulnerable?
Composer · 37 releases from 3.342.0 to 3.342.36 · latest aws/aws-sdk-php is 3.402.5 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. aws/aws-sdk-php 3.342.36, the last 3.342 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2025-14761. Upgrade to 3.371.4 or later to fix all of them.
composer require aws/aws-sdk-php:^3.371.4Advisories affecting aws/aws-sdk-php 3.342.36
AWS SDK for PHP has CloudFront Policy Document Injection via Special Characters
- Affected
- >=3.11.7 <3.371.4
- Fixed in
- 3.371.4
AWS SDK for PHP's S3 Encryption Client has a Key Commitment Issue
- Affected
- <3.368.0
- Fixed in
- 3.368.0
Which of your client projects are still on aws/aws-sdk-php 3.342?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact aws/aws-sdk-php version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other aws/aws-sdk-php versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.