Is aws/aws-sdk-php 3.369 vulnerable?
Composer · 39 releases from 3.369.0 to 3.369.38 · latest aws/aws-sdk-php is 3.402.5 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. aws/aws-sdk-php 3.369.38, the last 3.369 release, is affected by 1 known security advisory (1 high). Upgrade to 3.371.4 or later to fix all of them.
Upgrade with:
composer require aws/aws-sdk-php:^3.371.4Advisories affecting aws/aws-sdk-php 3.369.38
AWS SDK for PHP has CloudFront Policy Document Injection via Special Characters
- Affected
- >=3.11.7 <3.371.4
- Fixed in
- 3.371.4
Which of your client projects are still on aws/aws-sdk-php 3.369?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact aws/aws-sdk-php version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other aws/aws-sdk-php versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.