Is ckeditor/ckeditor 4.24 vulnerable?
Composer · 1 release from 4.24.0 to 4.24.0 · latest ckeditor/ckeditor is 4.25.1 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. ckeditor/ckeditor 4.24.0, the last 4.24 release, is affected by 1 known security advisory (1 medium), including CVE-2024-43407. Upgrade to 4.25.0 or later to fix all of them.
Upgrade with:
composer require ckeditor/ckeditor:^4.25.0Advisories affecting ckeditor/ckeditor 4.24.0
Code Snippet GeSHi plugin in CKEditor 4 has reflected cross-site scripting (XSS) vulnerability
- Affected
- <4.25.0
- Fixed in
- 4.25.0
Which of your client projects are still on ckeditor/ckeditor 4.24?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ckeditor/ckeditor version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ckeditor/ckeditor versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.