Is codeigniter4/framework 4.4 vulnerable?

Composer · 9 releases from 4.4.0 to 4.4.8 · latest codeigniter4/framework is 4.7.5 · checked 1 Nov 2026

Yes: 7 known advisories

Yes. codeigniter4/framework 4.4.8, the last 4.4 release, is affected by 7 known security advisories (4 critical, 1 high, 2 medium), including CVE-2026-63223, CVE-2026-63221, CVE-2026-48062. 2 more affect earlier 4.4.x releases. Upgrade to 4.7.4 or later to fix all of them.

Upgrade with:composer require codeigniter4/framework:^4.7.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting codeigniter4/framework 4.4.8

  • CriticalCVE-2026-63223GHSA-mmj4-63m4-r6h57 Aug 2026

    CodeIgniter: Uploaded file extension validation bypass in `is_image` and `mime_in` rules

    Affected
    <4.7.4
    Fixed in
    4.7.4
  • HighCVE-2026-63222GHSA-hhmc-q9hp-r6627 Aug 2026

    CodeIgniter: Path traversal in UploadedFile::move() when using client-provided filenames

    Affected
    <4.7.4
    Fixed in
    4.7.4
  • CriticalCVE-2026-63221GHSA-c9w5-rwh3-7pm97 Aug 2026

    CodeIgniter: SQL injection in Query Builder deleteBatch() when used with where() conditions

    Affected
    >=4.3.0 <4.7.4
    Fixed in
    4.7.4
  • MediumCVE-2026-63220GHSA-7wmf-pw8j-mc787 Aug 2026

    CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()

    Affected
    <4.7.4
    Fixed in
    4.7.4
  • CriticalCVE-2026-48062GHSA-2gr4-ppc7-7mhx11 Jun 2026

    CodeIgniter4 has a validation bypass when uploading file extensions via `ext_in` rule

    Affected
    <4.7.3
    Fixed in
    4.7.3
  • CriticalCVE-2025-54418GHSA-9952-gv64-x94c28 Jul 2025

    CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability

    Affected
    <4.6.2
    Fixed in
    4.6.2
  • MediumCVE-2025-24013GHSA-x5mq-jjr3-vmx621 Jan 2025

    Missing validation of header name and value in codeigniter4/framework

    Affected
    <4.5.8
    Fixed in
    4.5.8

Fixed within 4.4.x, affecting earlier releases

  • HighCVE-2024-29904GHSA-39fp-mqmm-gxj629 Mar 2024

    CodeIgniter4 DoS Vulnerability

    Affected
    <4.4.7
    Fixed in
    4.4.7
  • HighCVE-2023-46240GHSA-hwxf-qxj7-7rfj30 Oct 2023

    CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment

    Affected
    <4.4.3
    Fixed in
    4.4.3

Which of your client projects are still on codeigniter4/framework 4.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact codeigniter4/framework version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other codeigniter4/framework versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.