Is drupal/core 11.1 vulnerable?
Composer · 11 releases from 11.1.0 to 11.1.10 · latest drupal/core is 11.4.11 · checked 1 Nov 2026
Yes: 15 known advisories
Yes. drupal/core 11.1.10, the last 11.1 release, is affected by 15 known security advisories (2 medium, 13 low), including CVE-2026-6365, CVE-2026-6366, CVE-2026-108514. 18 more affect earlier 11.1.x releases. Upgrade to 11.3.19 or later to fix all of them.
composer require drupal/core:^11.3.19Advisories affecting drupal/core 11.1.10
No summary published
- Affected
- >=10.3.0 <10.6.19 · >=11.0.0 <11.3.19 · >=11.4.0 <11.4.10 · >=12.0.0-alpha1 <12.0.0-beta2
- Fixed in
- 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2
No summary published
- Affected
- >=8.9.0 <10.6.19 · >=11.0.0 <11.3.19 · >=11.4.0 <11.4.10 · >=12.0.0-alpha1 <12.0.0-beta2
- Fixed in
- 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2
No summary published
- Affected
- >=8.9.0 <10.6.19 · >=11.0.0 <11.3.19 · >=11.4.0 <11.4.10 · >=12.0.0-alpha1 <12.0.0-beta2
- Fixed in
- 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2
No summary published
- Affected
- >=10.5.0 <10.6.17 · >=11.0.0 <11.3.17 · >=11.4.0 <11.4.7
- Fixed in
- 10.6.17, 11.3.17, 11.4.7
No summary published
- Affected
- <10.6.13 · >=11.3.0 <11.3.14 · >=11.4.0 <11.4.4 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0 · >=11.2.0 <11.3.0
- Fixed in
- 10.6.13, 11.1.0, 11.2.0, 11.3.0, 11.3.14, 11.4.4
No summary published
- Affected
- <10.6.13 · >=11.3.0 <11.3.14 · >=11.4.0 <11.4.4 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0 · >=11.2.0 <11.3.0
- Fixed in
- 10.6.13, 11.1.0, 11.2.0, 11.3.0, 11.3.14, 11.4.4
No summary published
- Affected
- <10.5.12 · >=10.6.0 <10.6.11 · >=11.2.0 <11.2.14 · >=11.3.0 <11.3.12 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0
- Fixed in
- 10.5.12, 10.6.11, 11.1.0, 11.2.0, 11.2.14, 11.3.12
No summary published
- Affected
- <10.5.12 · >=10.6.0 <10.6.11 · >=11.2.0 <11.2.14 · >=11.3.0 <11.3.12 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0
- Fixed in
- 10.5.12, 10.6.11, 11.1.0, 11.2.0, 11.2.14, 11.3.12
No summary published
- Affected
- <10.5.12 · >=10.6.0 <10.6.11 · >=11.2.0 <11.2.14 · >=11.3.0 <11.3.12 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0
- Fixed in
- 10.5.12, 10.6.11, 11.1.0, 11.2.0, 11.2.14, 11.3.12
No summary published
- Affected
- <10.5.12 · >=10.6.0 <10.6.11 · >=11.2.0 <11.2.14 · >=11.3.0 <11.3.12 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0
- Fixed in
- 10.5.12, 10.6.11, 11.1.0, 11.2.0, 11.2.14, 11.3.12
No summary published
- Affected
- <10.5.12 · >=10.6.0 <10.6.11 · >=11.2.0 <11.2.14 · >=11.3.0 <11.3.12 · >=11.0.0 <11.1.0 · >=11.1.0 <11.2.0
- Fixed in
- 10.5.12, 10.6.11, 11.1.0, 11.2.0, 11.2.14, 11.3.12
Drupal core is Vulnerable to Cross-Site Scripting
- Affected
- >=8.0.0 <10.5.9 · >=10.6.0 <10.6.7 · >=11.0.0 <11.2.11 · >=11.3.0 <11.3.7
- Fixed in
- 10.5.9, 10.6.7, 11.2.11, 11.3.7
Drupal core allows Object Injection
- Affected
- >=8.0.0 <10.5.9 · >=10.6.0 <10.6.7 · >=11.0.0 <11.2.11 · >=11.3.0 <11.3.7
- Fixed in
- 10.5.9, 10.6.7, 11.2.11, 11.3.7
No summary published
- Affected
- >=8.0.0 <10.5.9 · >=10.6.0 <10.6.7 · >=11.0.0 <11.2.11 · >=11.3.0 <11.3.7
- Fixed in
- 10.5.9, 10.6.7, 11.2.11, 11.3.7
No summary published
- Affected
- >=8.0.0 <10.5.9 · >=10.6.0 <10.6.7 · >=11.0.0 <11.2.11 · >=11.3.0 <11.3.7
- Fixed in
- 10.5.9, 10.6.7, 11.2.11, 11.3.7
Fixed within 11.1.x, affecting earlier releases
Drupal Core has a SQL Injection issue
- Affected
- >=8.9.0 <10.4.10 · >=10.5.0 <10.5.10 · >=10.6.0 <10.6.9 · >=11.0.0 <11.1.10 · >=11.2.0 <11.2.12 · >=11.3.0 <11.3.10
- Fixed in
- 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10
No summary published
- Affected
- >=8.9.0 <10.4.10 · >=10.5.0 <10.5.10 · >=10.6.0 <10.6.9 · >=11.0.0 <11.1.10 · >=11.2.0 <11.2.12 · >=11.3.0 <11.3.10
- Fixed in
- 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10
Drupal core allows Object Injection
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
Drupal core allows Forceful Browsing
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
Drupal core allows Content Spoofing
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8 · >=7.0 <7.103
- Fixed in
- 7.103, 10.4.9, 10.5.6, 11.1.9, 11.2.8
No summary published
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
No summary published
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
No summary published
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
No summary published
- Affected
- >=8.0.0 <10.4.9 · >=10.5.0 <10.5.6 · >=11.0.0 <11.1.9 · >=11.2.0 <11.2.8
- Fixed in
- 10.4.9, 10.5.6, 11.1.9, 11.2.8
Drupal Core Potential Cross-Site Scripting (XSS) via Error Messages
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
Drupal Core Improperly Controlled Modification of Dynamically-Determined Object Attributes Vulnerability
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
Drupal Core Vulnerable to Forceful Browsing
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
Drupal Core Cross-Site Scripting (XSS) Vulnerability
- Affected
- >=8.0.0 <10.3.14 · >=10.4.0 <10.4.5 · >=11.0.0 <11.0.13 · >=11.1.0 <11.1.5
- Fixed in
- 10.3.14, 10.4.5, 11.0.13, 11.1.5
No summary published
- Affected
- >=8.0.0 <10.3.14 · >=10.4.0 <10.4.5 · >=11.0.0 <11.0.13 · >=11.1.0 <11.1.5
- Fixed in
- 10.3.14, 10.4.5, 11.0.13, 11.1.5
No summary published
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
No summary published
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
No summary published
- Affected
- >=8.0.0 <10.3.13 · >=10.4.0 <10.4.3 · >=11.0.0 <11.0.12 · >=11.1.0 <11.1.3
- Fixed in
- 10.3.13, 10.4.3, 11.0.12, 11.1.3
Which of your client projects are still on drupal/core 11.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact drupal/core version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other drupal/core versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.