Is illuminate/database 4.1 vulnerable?

Composer · 31 releases from 4.1.0 to 4.1.30 · latest illuminate/database is 13.40.0 · checked 5 Nov 2026

Yes: 2 known advisories

Yes. illuminate/database 4.1.30, the last 4.1 release, is affected by 2 known security advisories (2 high). 1 more affects earlier 4.1.x releases. Upgrade to 6.20.26 or later to fix all of them.

Upgrade with:composer require illuminate/database:^6.20.26

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Get an email when illuminate/database has a new advisory

We confirm your address first. See our privacy policy.

Advisories affecting illuminate/database 4.1.30

  • HighGHSA-4mg9-vhxq-vm7j29 Apr 2021

    SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

    Affected
    >=8.0.0 <8.40.0 · <6.20.26
    Fixed in
    6.20.26, 8.40.0
  • HighGHSA-x7p5-p2c9-phvg2 Feb 2021

    Unexpected database bindings

    Affected
    <6.20.14 · >=7.0.0 <7.30.4 · >=8.0.0 <8.24.0
    Fixed in
    6.20.14, 7.30.4, 8.24.0

Fixed within 4.1.x, affecting earlier releases

  • MediumGHSA-cc2w-ghc5-m5qr15 May 2024

    Laravel Risk of mass-assignment vulnerabilities

    Affected
    >=4.0.0 <4.1.29
    Fixed in
    4.1.29

Which of your client projects are still on illuminate/database 4.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact illuminate/database version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other illuminate/database versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.