Is illuminate/database 5.5 vulnerable?
Composer · 15 releases from 5.5.0 to 5.5.44 · latest illuminate/database is 13.40.0 · checked 5 Nov 2026
Yes: 3 known advisories
Yes. illuminate/database 5.5.44, the last 5.5 release, is affected by 3 known security advisories (3 high), including CVE-2020-24940. Upgrade to 6.20.26 or later to fix all of them.
composer require illuminate/database:^6.20.26Advisories affecting illuminate/database 5.5.44
Guard bypass in Eloquent models affecting Laravel illuminate database component
- Affected
- >=5.5.0 <=5.5.44 · >=6.0.0 <6.18.34 · >=7.0.0 <7.23.2
- Fixed in
- 6.18.34, 7.23.2
SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database
- Affected
- >=8.0.0 <8.40.0 · <6.20.26
- Fixed in
- 6.20.26, 8.40.0
Unexpected database bindings
- Affected
- <6.20.14 · >=7.0.0 <7.30.4 · >=8.0.0 <8.24.0
- Fixed in
- 6.20.14, 7.30.4, 8.24.0
Which of your client projects are still on illuminate/database 5.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact illuminate/database version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other illuminate/database versions
- illuminate/database 5.8
- illuminate/database 5.7
- illuminate/database 5.6
- illuminate/database 5.4
- illuminate/database 5.3
- illuminate/database 5.2
- illuminate/database 13.40
- illuminate/database 13.39
- illuminate/database 13.38
- illuminate/database 13.37
- illuminate/database 13.36
- illuminate/database 13.35
- All illuminate/database advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.