Is illuminate/database 7.9 vulnerable?

Composer · 3 releases from 7.9.0 to 7.9.2 · latest illuminate/database is 13.40.0 · checked 5 Nov 2026

Yes: 3 known advisories

Yes. illuminate/database 7.9.2, the last 7.9 release, is affected by 3 known security advisories (3 high), including CVE-2020-24940, CVE-2021-21263. Upgrade to 7.30.4 or later to fix all of them.

Upgrade with:composer require illuminate/database:^7.30.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Get an email when illuminate/database has a new advisory

We confirm your address first. See our privacy policy.

Advisories affecting illuminate/database 7.9.2

  • HighCVE-2020-24940GHSA-c7rm-w2hj-x8g324 May 2022

    Guard bypass in Eloquent models affecting Laravel illuminate database component

    Affected
    >=5.5.0 <=5.5.44 · >=6.0.0 <6.18.34 · >=7.0.0 <7.23.2
    Fixed in
    6.18.34, 7.23.2
  • HighGHSA-x7p5-p2c9-phvg2 Feb 2021

    Unexpected database bindings

    Affected
    <6.20.14 · >=7.0.0 <7.30.4 · >=8.0.0 <8.24.0
    Fixed in
    6.20.14, 7.30.4, 8.24.0
  • HighCVE-2021-21263GHSA-3p32-j457-pg5x19 Jan 2021

    Query Binding Exploitation

    Affected
    >=7.0.0 <7.30.3 · >=8.0.0 <8.22.1 · >=6.0.0 <6.20.12
    Fixed in
    6.20.12, 7.30.3, 8.22.1

Which of your client projects are still on illuminate/database 7.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact illuminate/database version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other illuminate/database versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.