Is illuminate/database 8.15 vulnerable?

Composer · 1 release from 8.15.0 to 8.15.0 · latest illuminate/database is 13.40.0 · checked 5 Nov 2026

Yes: 3 known advisories

Yes. illuminate/database 8.15.0, the last 8.15 release, is affected by 3 known security advisories (3 high), including CVE-2021-21263. Upgrade to 8.40.0 or later to fix all of them.

Upgrade with:composer require illuminate/database:^8.40.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Get an email when illuminate/database has a new advisory

We confirm your address first. See our privacy policy.

Advisories affecting illuminate/database 8.15.0

  • HighGHSA-4mg9-vhxq-vm7j29 Apr 2021

    SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

    Affected
    >=8.0.0 <8.40.0 · <6.20.26
    Fixed in
    6.20.26, 8.40.0
  • HighGHSA-x7p5-p2c9-phvg2 Feb 2021

    Unexpected database bindings

    Affected
    <6.20.14 · >=7.0.0 <7.30.4 · >=8.0.0 <8.24.0
    Fixed in
    6.20.14, 7.30.4, 8.24.0
  • HighCVE-2021-21263GHSA-3p32-j457-pg5x19 Jan 2021

    Query Binding Exploitation

    Affected
    >=7.0.0 <7.30.3 · >=8.0.0 <8.22.1 · >=6.0.0 <6.20.12
    Fixed in
    6.20.12, 7.30.3, 8.22.1

Which of your client projects are still on illuminate/database 8.15?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact illuminate/database version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other illuminate/database versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.