Is illuminate/database 8.25 vulnerable?
Composer · 1 release from 8.25.0 to 8.25.0 · latest illuminate/database is 13.40.0 · checked 5 Nov 2026
Yes: 1 known advisory
Yes. illuminate/database 8.25.0, the last 8.25 release, is affected by 1 known security advisory (1 high). Upgrade to 8.40.0 or later to fix all of them.
Upgrade with:
composer require illuminate/database:^8.40.0Advisories affecting illuminate/database 8.25.0
SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database
- Affected
- >=8.0.0 <8.40.0 · <6.20.26
- Fixed in
- 6.20.26, 8.40.0
Which of your client projects are still on illuminate/database 8.25?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact illuminate/database version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other illuminate/database versions
- illuminate/database 8.28
- illuminate/database 8.27
- illuminate/database 8.26
- illuminate/database 8.24
- illuminate/database 8.23
- illuminate/database 8.22
- illuminate/database 13.40
- illuminate/database 13.39
- illuminate/database 13.38
- illuminate/database 13.37
- illuminate/database 13.36
- illuminate/database 13.35
- All illuminate/database advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.