Is laminas/laminas-diactoros 2.1 vulnerable?
Composer · 6 releases from 2.1.0 to 2.1.5 · latest laminas/laminas-diactoros is 3.9.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. laminas/laminas-diactoros 2.1.5, the last 2.1 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2023-29530, CVE-2022-31109. Upgrade to 2.18.1 or later to fix all of them.
composer require laminas/laminas-diactoros:^2.18.1Advisories affecting laminas/laminas-diactoros 2.1.5
HTTP Multiline Header Termination
- Affected
- <2.18.1 · >=2.19.0 <2.19.1 · >=2.20.0 <2.20.1 · >=2.21.0 <2.21.1 · >=2.22.0 <2.22.1 · >=2.23.0 <2.23.1 · >=2.24.0 <2.24.2 · >=2.25.0 <2.25.2
- Fixed in
- 2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.2, 2.25.2
Diactoros before 2.11.1 vulnerable to HTTP Host Header Attack
- Affected
- <2.11.1
- Fixed in
- 2.11.1
Which of your client projects are still on laminas/laminas-diactoros 2.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact laminas/laminas-diactoros version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other laminas/laminas-diactoros versions
- laminas/laminas-diactoros 2.4
- laminas/laminas-diactoros 2.3
- laminas/laminas-diactoros 2.2
- laminas/laminas-diactoros 2.0
- laminas/laminas-diactoros 1.8
- laminas/laminas-diactoros 1.7
- laminas/laminas-diactoros 3.9
- laminas/laminas-diactoros 3.8
- laminas/laminas-diactoros 3.7
- laminas/laminas-diactoros 3.6
- laminas/laminas-diactoros 3.5
- laminas/laminas-diactoros 3.4
- All laminas/laminas-diactoros advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.