Is laminas/laminas-diactoros 2.12 vulnerable?

Composer · 1 release from 2.12.0 to 2.12.0 · latest laminas/laminas-diactoros is 3.9.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. laminas/laminas-diactoros 2.12.0, the last 2.12 release, is affected by 1 known security advisory (1 high), including CVE-2023-29530. Upgrade to 2.18.1 or later to fix all of them.

Upgrade with:composer require laminas/laminas-diactoros:^2.18.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting laminas/laminas-diactoros 2.12.0

  • HighCVE-2023-29530GHSA-xv3h-4844-9h3624 Apr 2023

    HTTP Multiline Header Termination

    Affected
    <2.18.1 · >=2.19.0 <2.19.1 · >=2.20.0 <2.20.1 · >=2.21.0 <2.21.1 · >=2.22.0 <2.22.1 · >=2.23.0 <2.23.1 · >=2.24.0 <2.24.2 · >=2.25.0 <2.25.2
    Fixed in
    2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.2, 2.25.2

Which of your client projects are still on laminas/laminas-diactoros 2.12?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact laminas/laminas-diactoros version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other laminas/laminas-diactoros versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.