Is laravel/framework 12.58 vulnerable?
Composer · 1 release from 12.58.0 to 12.58.0 · latest laravel/framework is 13.39.0 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. laravel/framework 12.58.0, the last 12.58 release, is affected by 5 known security advisories (1 critical, 1 high, 2 medium, 1 low), including CVE-2026-114509, CVE-2026-48019, CVE-2026-114508. Upgrade to 12.69.0 or later to fix all of them.
composer require laravel/framework:^12.69.0Advisories affecting laravel/framework 12.58.0
Laravel TokenGuard authentication bypass through non-string API credentials
- Affected
- >=13.0.0 <13.29.0 · <12.68.0
- Fixed in
- 12.68.0, 13.29.0
Laravel relationship inclusion can trigger unauthorized data destruction
- Affected
- >=12.45.0 <12.68.0 · >=13.0.0 <13.27.0
- Fixed in
- 12.68.0, 13.27.0
Laravel: XSS in Debug Page Information
- Affected
- <12.69.0 · >=13.0.0 <13.30.0
- Fixed in
- 12.69.0, 13.30.0
Laravel Framework: Temporary Signed URL Path Confusion
- Affected
- >=13.0.0 <13.12.0 · <12.61.1
- Fixed in
- 12.61.1, 13.12.0
Laravel Framework: CRLF injection in default email rule
- Affected
- >=13.0.0 <13.10.0 · <12.60.0
- Fixed in
- 12.60.0, 13.10.0
Which of your client projects are still on laravel/framework 12.58?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact laravel/framework version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other laravel/framework versions
- laravel/framework 12.61
- laravel/framework 12.60
- laravel/framework 12.59
- laravel/framework 12.57
- laravel/framework 12.56
- laravel/framework 12.55
- laravel/framework 13.39
- laravel/framework 13.38
- laravel/framework 13.37
- laravel/framework 13.36
- laravel/framework 13.35
- laravel/framework 13.34
- All laravel/framework advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.