Is laravel/socialite 1.0 vulnerable?
Composer · 4 releases from 1.0.0 to 1.0.3 · latest laravel/socialite is 5.31.0 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. laravel/socialite 1.0.3, the last 1.0 release, is affected by 2 known security advisories (2 medium). Upgrade to 2.0.10 or later to fix all of them.
Upgrade with:
composer require laravel/socialite:^2.0.10Advisories affecting laravel/socialite 1.0.3
Insecure State Generation in laravel/socialite
- Affected
- >=1.0.0 <2.0.9
- Fixed in
- 2.0.9
State Guessing Vulnerability in laravel/socialite
- Affected
- >=1.0.0 <2.0.10
- Fixed in
- 2.0.10
Which of your client projects are still on laravel/socialite 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact laravel/socialite version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other laravel/socialite versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.