Is league/commonmark 0.11 vulnerable?

Composer · 4 releases from 0.11.0 to 0.11.3 · latest league/commonmark is 2.10.7 · checked 2 Nov 2026

Yes: 4 known advisories

Yes. league/commonmark 0.11.3, the last 0.11 release, is affected by 4 known security advisories (3 high, 1 medium), including CVE-2026-86430, CVE-2026-71488, CVE-2024-58382. Upgrade to 2.9.1 or later to fix all of them.

Upgrade with:composer require league/commonmark:^2.9.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting league/commonmark 0.11.3

  • HighCVE-2026-86430GHSA-j8pm-gj4c-rq4x1 Sept 2026

    league/commonmark: Denial of service via crafted code fences, reference links, and emphasis delimiters

    Affected
    >=0.6.0 <2.9.1
    Fixed in
    2.9.1
  • HighCVE-2026-71488GHSA-2q4p-g7hv-5rgv6 Aug 2026

    league/commonmark: Quadratic-time denial of service when parsing crafted Markdown

    Affected
    >=0.6.0 <2.9.0
    Fixed in
    2.9.0
  • HighCVE-2024-58382GHSA-c2pc-g5qf-rfrf9 Dec 2024

    league/commonmark's quadratic complexity bugs may lead to a denial of service

    Affected
    <2.6.0
    Fixed in
    2.6.0
  • MediumCVE-2019-10010GHSA-3v43-877x-qgmq17 Sept 2019

    Moderate severity vulnerability that affects league/commonmark

    Affected
    <0.18.3
    Fixed in
    0.18.3

Which of your client projects are still on league/commonmark 0.11?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact league/commonmark version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other league/commonmark versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.