Is league/flysystem 3.35 vulnerable?

Composer · 4 releases from 3.35.0 to 3.35.3 · latest league/flysystem is 3.36.0 · checked 2 Nov 2026

No known advisories in the last release

league/flysystem 3.35.3, the last 3.35 release, has no known advisories. 1 advisory affects earlier 3.35.x releases, so update to 3.35.3.

Update within 3.35:composer require league/flysystem:^3.35.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 3.35.x, affecting earlier releases

  • LowCVE-2026-102601GHSA-cxf4-7mrp-vvpr29 Sept 2026

    Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter

    Affected
    <3.35.3
    Fixed in
    3.35.3

Which of your client projects are still on league/flysystem 3.35?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact league/flysystem version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other league/flysystem versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.