Is monolog/monolog 1.9 vulnerable?

Composer · 2 releases from 1.9.0 to 1.9.1 · latest monolog/monolog is 3.12.1 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. monolog/monolog 1.9.1, the last 1.9 release, is affected by 1 known security advisory (1 low). Upgrade to 1.12.0 or later to fix all of them.

Upgrade with:composer require monolog/monolog:^1.12.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting monolog/monolog 1.9.1

  • LowGHSA-f57v-q966-7fh615 May 2024

    Monolog Header injection in NativeMailerHandler

    Affected
    >=1.8.0 <1.12.0
    Fixed in
    1.12.0

Which of your client projects are still on monolog/monolog 1.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact monolog/monolog version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other monolog/monolog versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.