Is phpseclib/phpseclib 4.0 vulnerable?
Composer · 4 releases from 4.0.0 to 4.0.3 · latest phpseclib/phpseclib is 4.0.3 · checked 2 Nov 2026
No known advisories in the last release
phpseclib/phpseclib 4.0.3, the last 4.0 release, has no known advisories. 1 advisory affects earlier 4.0.x releases, so update to 4.0.3.
Update within 4.0:
composer require phpseclib/phpseclib:^4.0.3Fixed within 4.0.x, affecting earlier releases
phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery
- Affected
- <3.0.57 · >=4.0.0 <4.0.1
- Fixed in
- 3.0.57, 4.0.1
Which of your client projects are still on phpseclib/phpseclib 4.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpseclib/phpseclib version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpseclib/phpseclib versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.