Is slim/slim 4.15 vulnerable?
Composer · 4 releases from 4.15.0 to 4.15.3 · latest slim/slim is 4.15.3 · checked 1 Nov 2026
No known advisories in the last release
slim/slim 4.15.3, the last 4.15 release, has no known advisories. 1 advisory affects earlier 4.15.x releases, so update to 4.15.3.
Update within 4.15:
composer require slim/slim:^4.15.3Fixed within 4.15.x, affecting earlier releases
Slim has Reflected XSS in the HtmlErrorRenderer
- Affected
- >=4.4.0 <4.15.2
- Fixed in
- 4.15.2
Which of your client projects are still on slim/slim 4.15?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact slim/slim version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other slim/slim versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.