Is symfony/http-foundation 2.3 vulnerable?

Composer · 43 releases from 2.3.0 to 2.3.42 · latest symfony/http-foundation is 8.1.10 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. symfony/http-foundation 2.3.42, the last 2.3 release, is affected by 3 known security advisories (2 high, 1 low), including CVE-2025-64500, CVE-2019-18888, CVE-2024-50345. 4 more affect earlier 2.3.x releases. Upgrade to 5.4.50 or later to fix all of them.

Upgrade with:composer require symfony/http-foundation:^5.4.50

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/http-foundation 2.3.42

  • HighCVE-2025-64500GHSA-3rg7-wf37-54rm12 Nov 2025

    Symfony's incorrect parsing of PATH_INFO can lead to limited authorization bypass

    Affected
    <5.4.50 · >=6.0.0 <6.4.29 · >=7.0.0 <7.3.7
    Fixed in
    5.4.50, 6.4.29, 7.3.7
  • LowCVE-2024-50345GHSA-mrqx-rp3w-jpjp6 Nov 2024

    Symfony vulnerable to open redirect via browser-sanitized URLs

    Affected
    <5.4.46 · >=6.0.0 <6.4.14 · >=7.0.0 <7.1.7
    Fixed in
    5.4.46, 6.4.14, 7.1.7
  • HighCVE-2019-18888GHSA-xhh6-956q-4q692 Dec 2019

    Argument injection in a MimeTypeGuesser in Symfony

    Affected
    >=2.0.0 <2.8.52 · >=3.0.0 <3.4.35 · >=4.0.0 <4.2.12 · >=4.3.0 <4.3.8
    Fixed in
    2.8.52, 3.4.35, 4.2.12, 4.3.8

Fixed within 2.3.x, affecting earlier releases

  • MediumCVE-2015-2309GHSA-p684-f7fh-jv2j30 May 2024

    Symfony has unsafe methods in the Request class

    Affected
    >=2.0.0 <2.3.27 · >=2.4.0 <2.5.11 · >=2.6.0 <2.6.6
    Fixed in
    2.3.27, 2.5.11, 2.6.6
  • MediumCVE-2014-6061GHSA-h7v2-2qwg-h82930 May 2024

    Symfony has a security issue when parsing the Authorization header

    Affected
    >=2.0.0 <2.3.19 · >=2.4.0 <2.4.9 · >=2.5.0 <2.5.4
    Fixed in
    2.3.19, 2.4.9, 2.5.4
  • HighCVE-2014-5244GHSA-v77v-x634-9m5630 May 2024

    Symfony vulnerable to denial of service via a malicious HTTP Host header

    Affected
    >=2.0.0 <2.3.19 · >=2.4.0 <2.4.9 · >=2.5.0 <2.5.4
    Fixed in
    2.3.19, 2.4.9, 2.5.4
  • MediumCVE-2013-4752GHSA-22pv-7v9j-hqxp5 May 2022

    Symfony Host Header Injection vulnerability in the HttpFoundation component

    Affected
    >=2.0.0 <2.0.24 · >=2.1.0 <2.1.12 · >=2.2.0 <2.2.5 · >=2.3.0 <2.3.3
    Fixed in
    2.0.24, 2.1.12, 2.2.5, 2.3.3

Which of your client projects are still on symfony/http-foundation 2.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-foundation version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-foundation versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.