Is symfony/routing 5.3 vulnerable?
Composer · 5 releases from 5.3.0 to 5.3.14 · latest symfony/routing is 8.1.10 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. symfony/routing 5.3.14, the last 5.3 release, is affected by 2 known security advisories (2 medium), including CVE-2026-48784, CVE-2026-45065. Upgrade to 5.4.53 or later to fix all of them.
composer require symfony/routing:^5.4.53Advisories affecting symfony/routing 5.3.14
Symfony: UrlGenerator Dot-Segment Encoding Skips Every Other Chained `../` or `./` → Generated URL Collapses Off-Route Under RFC 3986 Normalization
- Affected
- <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
- Fixed in
- 5.4.53, 6.4.41, 7.4.13, 8.0.13
Symfony has a UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection
- Affected
- <5.4.52 · >=6.0.0 <6.4.40 · >=7.0.0 <7.4.12 · >=8.0.0 <8.0.12
- Fixed in
- 5.4.52, 6.4.40, 7.4.12, 8.0.12
Which of your client projects are still on symfony/routing 5.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/routing version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/routing versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.