Is symfony/security-http 7.2 vulnerable?
Composer · 8 releases from 7.2.0 to 7.2.9 · latest symfony/security-http is 8.1.10 · checked 1 Nov 2026
Yes: 3 known advisories
Yes. symfony/security-http 7.2.9, the last 7.2 release, is affected by 3 known security advisories (2 high, 1 medium), including CVE-2026-48489, CVE-2026-45063, CVE-2026-45074. Upgrade to 7.4.13 or later to fix all of them.
composer require symfony/security-http:^7.4.13Advisories affecting symfony/security-http 7.2.9
Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes
- Affected
- <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
- Fixed in
- 5.4.53, 6.4.41, 7.4.13, 8.0.13
Symfony's Cas2Handler Derives CAS service URL from Client Host Header → Cross-Service Ticket Replay
- Affected
- >=7.1.0 <7.4.12 · >=8.0.0 <8.0.12
- Fixed in
- 7.4.12, 8.0.12
Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator
- Affected
- <5.4.52 · >=6.0.0-BETA1 <6.4.40 · >=7.0.0-BETA1 <7.4.12 · >=8.0.0-BETA1 <8.0.12
- Fixed in
- 5.4.52, 6.4.40, 7.4.12, 8.0.12
Which of your client projects are still on symfony/security-http 7.2?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/security-http version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/security-http versions
- symfony/security-http 8.0
- symfony/security-http 7.4
- symfony/security-http 7.3
- symfony/security-http 7.1
- symfony/security-http 7.0
- symfony/security-http 6.4
- symfony/security-http 8.1
- symfony/security-http 6.3
- symfony/security-http 6.2
- symfony/security-http 6.1
- symfony/security-http 6.0
- All symfony/security-http advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.