Is @babel/core 7.22 vulnerable?
npm · 14 releases from 7.22.0 to 7.22.20 · latest @babel/core is 8.0.10 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. @babel/core 7.22.20, the last 7.22 release, is affected by 1 known security advisory (1 low), including CVE-2026-49356. Upgrade to 7.29.6 or later to fix all of them.
Upgrade with:
npm install @babel/core@7.29.6Advisories affecting @babel/core 7.22.20
@babel/core: Arbitrary File Read via sourceMappingURL Comment
- Affected
- >=8.0.0-alpha.0 <8.0.0-rc.6 · <7.29.6
- Fixed in
- 7.29.6, 8.0.0-rc.6
Which of your client projects are still on @babel/core 7.22?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @babel/core version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @babel/core versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.