Is @babel/traverse 7.23 vulnerable?
npm · 8 releases from 7.23.0 to 7.23.9 · latest @babel/traverse is 8.0.10 · checked 2 Nov 2026
No known advisories in the last release
@babel/traverse 7.23.9, the last 7.23 release, has no known advisories. 1 advisory affects earlier 7.23.x releases, so update to 7.23.9.
Update within 7.23:
npm install @babel/traverse@7.23.9Fixed within 7.23.x, affecting earlier releases
Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code
- Affected
- <7.23.2 · >=8.0.0-alpha.0 <8.0.0-alpha.4
- Fixed in
- 7.23.2, 8.0.0-alpha.4
Which of your client projects are still on @babel/traverse 7.23?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @babel/traverse version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @babel/traverse versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.