Is @babel/traverse 7.8 vulnerable?
npm · 4 releases from 7.8.0 to 7.8.6 · latest @babel/traverse is 8.0.10 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. @babel/traverse 7.8.6, the last 7.8 release, is affected by 1 known security advisory (1 critical), including CVE-2023-45133. Upgrade to 7.23.2 or later to fix all of them.
Upgrade with:
npm install @babel/traverse@7.23.2Advisories affecting @babel/traverse 7.8.6
Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code
- Affected
- <7.23.2 · >=8.0.0-alpha.0 <8.0.0-alpha.4
- Fixed in
- 7.23.2, 8.0.0-alpha.4
Which of your client projects are still on @babel/traverse 7.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @babel/traverse version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @babel/traverse versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.