Is @clerk/nextjs 5.5 vulnerable?
npm · 6 releases from 5.5.0 to 5.5.5 · latest @clerk/nextjs is 7.9.23 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. @clerk/nextjs 5.5.5, the last 5.5 release, is affected by 1 known security advisory (1 critical), including CVE-2026-41248. Upgrade to 5.7.6 or later to fix all of them.
Upgrade with:
npm install @clerk/nextjs@5.7.6Advisories affecting @clerk/nextjs 5.5.5
Official Clerk JavaScript SDKs: Middleware-based route protection bypass
- Affected
- >=5.0.0 <5.7.6 · >=6.0.0-snapshot.vb87a27f <6.39.2 · >=7.0.0 <7.2.1
- Fixed in
- 5.7.6, 6.39.2, 7.2.1
Which of your client projects are still on @clerk/nextjs 5.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @clerk/nextjs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @clerk/nextjs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.