Is @clerk/nextjs 6.37 vulnerable?
npm · 6 releases from 6.37.0 to 6.37.5 · latest @clerk/nextjs is 7.9.23 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. @clerk/nextjs 6.37.5, the last 6.37 release, is affected by 2 known security advisories (1 critical, 1 high), including CVE-2026-41248, CVE-2026-42349. Upgrade to 6.39.3 or later to fix all of them.
npm install @clerk/nextjs@6.39.3Advisories affecting @clerk/nextjs 6.37.5
Clerk has an authorization bypass when combining organization, billing, or reverification checks
- Affected
- >=6.0.0 <6.39.3 · >=7.0.0 <7.2.4
- Fixed in
- 6.39.3, 7.2.4
Official Clerk JavaScript SDKs: Middleware-based route protection bypass
- Affected
- >=5.0.0 <5.7.6 · >=6.0.0-snapshot.vb87a27f <6.39.2 · >=7.0.0 <7.2.1
- Fixed in
- 5.7.6, 6.39.2, 7.2.1
Which of your client projects are still on @clerk/nextjs 6.37?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @clerk/nextjs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @clerk/nextjs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.