Is @remix-run/node 1.15 vulnerable?
npm · 1 release from 1.15.0 to 1.15.0 · latest @remix-run/node is 2.17.5 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. @remix-run/node 1.15.0, the last 1.15 release, is affected by 1 known security advisory (1 critical), including CVE-2025-61686. Upgrade to 2.17.2 or later to fix all of them.
Upgrade with:
npm install @remix-run/node@2.17.2Advisories affecting @remix-run/node 1.15.0
React Router has Path Traversal in File Session Storage
- Affected
- <2.17.2
- Fixed in
- 2.17.2
Which of your client projects are still on @remix-run/node 1.15?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @remix-run/node version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @remix-run/node versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.