Is @remix-run/node 2.8 vulnerable?

npm · 2 releases from 2.8.0 to 2.8.1 · latest @remix-run/node is 2.17.5 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. @remix-run/node 2.8.1, the last 2.8 release, is affected by 1 known security advisory (1 critical), including CVE-2025-61686. Upgrade to 2.17.2 or later to fix all of them.

Upgrade with:npm install @remix-run/node@2.17.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting @remix-run/node 2.8.1

  • CriticalCVE-2025-61686GHSA-9583-h5hc-x8cw8 Jan 2026

    React Router has Path Traversal in File Session Storage

    Affected
    <2.17.2
    Fixed in
    2.17.2

Which of your client projects are still on @remix-run/node 2.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @remix-run/node version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other @remix-run/node versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.