Is @sentry/nextjs 10.50 vulnerable?
npm · 1 release from 10.50.0 to 10.50.0 · latest @sentry/nextjs is 11.10.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. @sentry/nextjs 10.50.0, the last 10.50 release, is affected by 1 known security advisory (1 critical), including CVE-2026-114139. Upgrade to 10.75.2 or later to fix all of them.
Upgrade with:
npm install @sentry/nextjs@10.75.2Advisories affecting @sentry/nextjs 10.50.0
Sentry-Javascript: Middleware Bypass when using Tunnel route
- Affected
- >=9.36.0 <9.47.2 · >=10.0.0-alpha.0 <10.75.2 · >=11.0.0-alpha.0 <11.0.0-rc.1
- Fixed in
- 9.47.2, 10.75.2, 11.0.0-rc.1
Which of your client projects are still on @sentry/nextjs 10.50?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @sentry/nextjs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @sentry/nextjs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.