Is @sentry/node 8.43 vulnerable?

npm · 1 release from 8.43.0 to 8.43.0 · latest @sentry/node is 11.10.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. @sentry/node 8.43.0, the last 8.43 release, is affected by 1 known security advisory (1 low). Upgrade to 8.49.0 or later to fix all of them.

Upgrade with:npm install @sentry/node@8.49.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting @sentry/node 8.43.0

  • LowGHSA-r5w7-f542-q2j428 Jan 2025

    Potential DoS when using ContextLines integration

    Affected
    >=8.10.0 <8.49.0
    Fixed in
    8.49.0

Which of your client projects are still on @sentry/node 8.43?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @sentry/node version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other @sentry/node versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.