Is ajv 4.7 vulnerable?

npm · 8 releases from 4.7.0 to 4.7.7 · latest ajv is 8.20.0 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. ajv 4.7.7, the last 4.7 release, is affected by 2 known security advisories (2 medium), including CVE-2025-69873, CVE-2020-15366. Upgrade to 6.14.0 or later to fix all of them.

Upgrade with:npm install ajv@6.14.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ajv 4.7.7

  • MediumCVE-2025-69873GHSA-2g4f-4pwh-qvx611 Feb 2026

    ajv has ReDoS when using `$data` option

    Affected
    >=7.0.0-alpha.0 <8.18.0 · <6.14.0
    Fixed in
    6.14.0, 8.18.0
  • MediumCVE-2020-15366GHSA-v88g-cgmw-v5xw10 Feb 2022

    Prototype Pollution in Ajv

    Affected
    <6.12.3
    Fixed in
    6.12.3

Which of your client projects are still on ajv 4.7?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ajv version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ajv versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.