Is apollo-server 0.2 vulnerable?

npm · 8 releases from 0.2.1 to 0.2.8 · latest apollo-server is 3.13.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. apollo-server 0.2.8, the last 0.2 release, is affected by 1 known security advisory (1 medium). Upgrade to 2.14.2 or later to fix all of them.

Upgrade with:npm install apollo-server@2.14.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting apollo-server 0.2.8

  • MediumGHSA-w42g-7vfc-xf375 Jun 2020

    Introspection in schema validation in Apollo Server

    Affected
    <2.14.2
    Fixed in
    2.14.2

Which of your client projects are still on apollo-server 0.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact apollo-server version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other apollo-server versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.