Is apollo-server 2.25 vulnerable?
npm · 5 releases from 2.25.0 to 2.25.4 · latest apollo-server is 3.13.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. apollo-server 2.25.4, the last 2.25 release, is affected by 1 known security advisory (1 high), including CVE-2026-23897. 2 more affect earlier 2.25.x releases. At least one has no fixed release yet.
Advisories affecting apollo-server 2.25.4
Apollo Serve vulnerable to Denial of Service with `startStandaloneServer`
- Affected
- >=2.0.0 <=3.13.0
- Fixed in
- No fix released
Fixed within 2.25.x, affecting earlier releases
The graphql-upload library included in Apollo Server 2 is vulnerable to CSRF mutations
- Affected
- >=2.0.0 <2.25.4
- Fixed in
- 2.25.4
Cross-site Scripting Vulnerability in GraphQL Playground (distributed by Apollo Server)
- Affected
- >=2.0.0 <2.25.3 · >=3.0.0 <3.4.1
- Fixed in
- 2.25.3, 3.4.1
Which of your client projects are still on apollo-server 2.25?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact apollo-server version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other apollo-server versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.