Is body-parser 2.3 vulnerable?

npm · 1 release from 2.3.0 to 2.3.0 · latest body-parser is 2.4.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. body-parser 2.3.0, the last 2.3 release, is affected by 1 known security advisory (1 high), including CVE-2026-111181. Upgrade to 2.4.0 or later to fix all of them.

Upgrade with:npm install body-parser@2.4.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting body-parser 2.3.0

  • HighCVE-2026-111181GHSA-27r3-jxmh-p82823 Oct 2026

    body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body

    Affected
    >=2.0.0 <2.4.0 · <1.20.9
    Fixed in
    1.20.9, 2.4.0

Which of your client projects are still on body-parser 2.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact body-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other body-parser versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.