Is bootstrap 3.4 vulnerable?

npm · 2 releases from 3.4.0 to 3.4.1 · latest bootstrap is 5.3.8 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. bootstrap 3.4.1, the last 3.4 release, is affected by 2 known security advisories (2 medium), including CVE-2025-1647, CVE-2024-6485. 1 more affects earlier 3.4.x releases. At least one has no fixed release yet.

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting bootstrap 3.4.1

  • MediumCVE-2025-1647GHSA-q58r-hwc8-rm9j15 May 2025

    Bootstrap Vulnerable to Cross-Site Scripting in its Popover and Tooltip Components

    Affected
    3.4.1
    Fixed in
    No fix released
  • MediumCVE-2024-6485GHSA-vxmc-5x29-h64v11 Jul 2024

    Bootstrap Cross-Site Scripting (XSS) vulnerability for data-* attributes

    Affected
    >=1.4.0 <=3.4.1
    Fixed in
    No fix released

Fixed within 3.4.x, affecting earlier releases

  • MediumCVE-2019-8331GHSA-9v3m-8fp8-mj9922 Feb 2019

    Bootstrap Vulnerable to Cross-Site Scripting

    Affected
    >=4.0.0 <4.3.1 · >=3.0.0 <3.4.1
    Fixed in
    3.4.1, 4.3.1

Which of your client projects are still on bootstrap 3.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact bootstrap version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other bootstrap versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.