Is browserify-sign 4.0 vulnerable?
npm · 5 releases from 4.0.0 to 4.0.4 · latest browserify-sign is 4.2.6 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. browserify-sign 4.0.4, the last 4.0 release, is affected by 1 known security advisory (1 high), including CVE-2023-46234. Upgrade to 4.2.2 or later to fix all of them.
Upgrade with:
npm install browserify-sign@4.2.2Advisories affecting browserify-sign 4.0.4
browserify-sign upper bound check issue in `dsaVerify` leads to a signature forgery attack
- Affected
- >=2.6.0 <4.2.2
- Fixed in
- 4.2.2
Which of your client projects are still on browserify-sign 4.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact browserify-sign version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other browserify-sign versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.