Is cross-spawn 4.0 vulnerable?

npm · 2 releases from 4.0.0 to 4.0.2 · latest cross-spawn is 7.0.6 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. cross-spawn 4.0.2, the last 4.0 release, is affected by 1 known security advisory (1 high), including CVE-2024-21538. Upgrade to 6.0.6 or later to fix all of them.

Upgrade with:npm install cross-spawn@6.0.6

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting cross-spawn 4.0.2

  • HighCVE-2024-21538GHSA-3xgq-45jj-v2758 Nov 2024

    Regular Expression Denial of Service (ReDoS) in cross-spawn

    Affected
    >=7.0.0 <7.0.5 · <6.0.6
    Fixed in
    6.0.6, 7.0.5

Which of your client projects are still on cross-spawn 4.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact cross-spawn version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other cross-spawn versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.