Is css-what 1.0 vulnerable?

npm · 1 release from 1.0.0 to 1.0.0 · latest css-what is 8.0.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. css-what 1.0.0, the last 1.0 release, is affected by 1 known security advisory (1 high), including CVE-2022-21222. Upgrade to 2.1.3 or later to fix all of them.

Upgrade with:npm install css-what@2.1.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting css-what 1.0.0

  • HighCVE-2022-21222GHSA-p28h-cc7q-c4fg1 Oct 2022

    css-what vulnerable to ReDoS due to use of insecure regular expression

    Affected
    <2.1.3
    Fixed in
    2.1.3

Which of your client projects are still on css-what 1.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact css-what version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other css-what versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.