Is css-what 4.0 vulnerable?
npm · 1 release from 4.0.0 to 4.0.0 · latest css-what is 8.0.0 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. css-what 4.0.0, the last 4.0 release, is affected by 1 known security advisory (1 high), including CVE-2021-33587. Upgrade to 5.0.1 or later to fix all of them.
Upgrade with:
npm install css-what@5.0.1Advisories affecting css-what 4.0.0
Denial of service in css-what
- Affected
- >=4.0.0 <5.0.1
- Fixed in
- 5.0.1
Which of your client projects are still on css-what 4.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact css-what version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other css-what versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.