Is ejs 1.0 vulnerable?
npm · 1 release from 1.0.0 to 1.0.0 · latest ejs is 7.0.2 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. ejs 1.0.0, the last 1.0 release, is affected by 5 known security advisories (2 critical, 1 high, 2 medium), including CVE-2022-29078, CVE-2017-1000228, CVE-2017-1000189. Upgrade to 3.1.10 or later to fix all of them.
npm install ejs@3.1.10Advisories affecting ejs 1.0.0
ejs lacks certain pollution protection
- Affected
- <3.1.10
- Fixed in
- 3.1.10
ejs template injection vulnerability
- Affected
- <3.1.7
- Fixed in
- 3.1.7
ejs vulnerable to DoS due to weak input validation
- Affected
- <2.5.5
- Fixed in
- 2.5.5
ejs is vulnerable to remote code execution due to weak input validation
- Affected
- <2.5.5
- Fixed in
- 2.5.5
mde ejs vulnerable to XSS
- Affected
- <2.5.5
- Fixed in
- 2.5.5
Which of your client projects are still on ejs 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ejs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ejs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.