Is ejs 2.7 vulnerable?

npm · 4 releases from 2.7.1 to 2.7.4 · latest ejs is 7.0.2 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. ejs 2.7.4, the last 2.7 release, is affected by 2 known security advisories (1 critical, 1 medium), including CVE-2022-29078, CVE-2024-33883. Upgrade to 3.1.10 or later to fix all of them.

Upgrade with:npm install ejs@3.1.10

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ejs 2.7.4

  • MediumCVE-2024-33883GHSA-ghr5-ch3p-vcr628 Apr 2024

    ejs lacks certain pollution protection

    Affected
    <3.1.10
    Fixed in
    3.1.10
  • CriticalCVE-2022-29078GHSA-phwq-j96m-2c2q26 Apr 2022

    ejs template injection vulnerability

    Affected
    <3.1.7
    Fixed in
    3.1.7

Which of your client projects are still on ejs 2.7?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ejs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ejs versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.