Is elliptic 6.6 vulnerable?

npm · 2 releases from 6.6.0 to 6.6.1 · latest elliptic is 6.6.1 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. elliptic 6.6.1, the last 6.6 release, is affected by 1 known security advisory (1 low), including CVE-2025-14505. 1 more affects earlier 6.6.x releases. At least one has no fixed release yet.

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting elliptic 6.6.1

  • LowCVE-2025-14505GHSA-848j-6mx2-7j848 Jan 2026

    Elliptic Uses a Cryptographic Primitive with a Risky Implementation

    Affected
    <=6.6.1
    Fixed in
    No fix released

Fixed within 6.6.x, affecting earlier releases

  • CriticalGHSA-vjh7-7g9h-fjfh12 Feb 2025

    Elliptic's private key extraction in ECDSA upon signing a malformed input (e.g. a string)

    Affected
    <6.6.1
    Fixed in
    6.6.1

Which of your client projects are still on elliptic 6.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact elliptic version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other elliptic versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.