Is express 3.20 vulnerable?

npm · 4 releases from 3.20.0 to 3.20.3 · latest express is 5.3.0 · checked 1 Nov 2026

Yes: 4 known advisories

Yes. express 3.20.3, the last 3.20 release, is affected by 4 known security advisories (2 medium, 2 low), including CVE-2024-10491, CVE-2024-29041, CVE-2024-9266. Upgrade to 4.20.0 or later to fix all of them.

Upgrade with:npm install express@4.20.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting express 3.20.3

  • MediumCVE-2024-10491GHSA-cm5g-3pgc-8rg429 Oct 2024

    Express ressource injection

    Affected
    <4.0.0-rc1
    Fixed in
    4.0.0-rc1
  • LowCVE-2024-9266GHSA-jj78-5fmv-mv283 Oct 2024

    Express Open Redirect vulnerability

    Affected
    >=3.4.5 <4.0.0-rc1
    Fixed in
    4.0.0-rc1
  • LowCVE-2024-43796GHSA-qw6h-vgh9-j6wx10 Sept 2024

    express vulnerable to XSS via response.redirect()

    Affected
    <4.20.0 · >=5.0.0-alpha.1 <5.0.0
    Fixed in
    4.20.0, 5.0.0
  • MediumCVE-2024-29041GHSA-rv95-896h-c2vc25 Mar 2024

    Express.js Open Redirect in malformed URLs

    Affected
    <4.19.2 · >=5.0.0-alpha.1 <5.0.0-beta.3
    Fixed in
    4.19.2, 5.0.0-beta.3

Which of your client projects are still on express 3.20?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact express version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other express versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.