Is fast-xml-parser 5.9 vulnerable?

npm · 4 releases from 5.9.0 to 5.9.3 · latest fast-xml-parser is 5.11.2 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. fast-xml-parser 5.9.3, the last 5.9 release, is affected by 1 known security advisory (1 high), including CVE-2026-73569. Upgrade to 5.10.1 or later to fix all of them.

Upgrade with:npm install fast-xml-parser@5.10.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting fast-xml-parser 5.9.3

  • HighCVE-2026-73569GHSA-8r6m-32jq-jx6q21 Jul 2026

    fast-xml-parser: Repeated DOCTYPE declarations reset entity expansion limits

    Affected
    >=5.9.3 <5.10.1
    Fixed in
    5.10.1

Which of your client projects are still on fast-xml-parser 5.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact fast-xml-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other fast-xml-parser versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.