Is form-data 2.0 vulnerable?
npm · 1 release from 2.0.0 to 2.0.0 · latest form-data is 4.0.6 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. form-data 2.0.0, the last 2.0 release, is affected by 2 known security advisories (1 critical, 1 high), including CVE-2025-7783, CVE-2026-12143. Upgrade to 2.5.6 or later to fix all of them.
npm install form-data@2.5.6Advisories affecting form-data 2.0.0
form-data: CRLF injection in form-data via unescaped multipart field names and filenames
- Affected
- <2.5.6 · >=3.0.0 <3.0.5 · >=4.0.0 <4.0.6
- Fixed in
- 2.5.6, 3.0.5, 4.0.6
form-data uses unsafe random function in form-data for choosing boundary
- Affected
- <2.5.4 · >=3.0.0 <3.0.4 · >=4.0.0 <4.0.4
- Fixed in
- 2.5.4, 3.0.4, 4.0.4
Which of your client projects are still on form-data 2.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact form-data version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other form-data versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.