Is gatsby 2.28 vulnerable?

npm · 3 releases from 2.28.0 to 2.28.2 · latest gatsby is 5.16.1 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. gatsby 2.28.2, the last 2.28 release, is affected by 1 known security advisory (1 medium), including CVE-2023-34238. Upgrade to 4.25.7 or later to fix all of them.

Upgrade with:npm install gatsby@4.25.7

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting gatsby 2.28.2

  • MediumCVE-2023-34238GHSA-c6f8-8r25-c4gc9 Jun 2023

    Gatsby develop server has Local File Inclusion vulnerability

    Affected
    <4.25.7 · >=5.0.0 <5.9.1
    Fixed in
    4.25.7, 5.9.1

Which of your client projects are still on gatsby 2.28?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact gatsby version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other gatsby versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.