Is glob 9.3 vulnerable?
npm · 6 releases from 9.3.0 to 9.3.5 · latest glob is 14.0.3 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. glob 9.3.5, the last 9.3 release, is affected by 1 known security advisory (1 medium), including CVE-2026-118773. Upgrade to 14.0.2 or later to fix all of them.
Upgrade with:
npm install glob@14.0.2Advisories affecting glob 9.3.5
Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal
- Affected
- >=9.0.0 <14.0.2
- Fixed in
- 14.0.2
Which of your client projects are still on glob 9.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact glob version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other glob versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.